Clutch Slave Cylinder Smoking

Discussion in 'General Motoring' started by Lehma1989, May 23, 2020 at 3:41 PM.

  1. Lehma1989

    Lehma1989

    Joined:
    Saturday
    Messages:
    1
    Likes Received:
    0
    So I have a 2003 Forester with 230k. The clutch has been working fine, the only thing is every once in awhile it doesnt want to shift into reverse. (I just shift into another gear and then back to reverse and it always works). Clutch fluid is full and I have not seen any noticable leaks. Anyway, on my way up my 2 mile driveway my car started smoking and smelled aweful. Opened up the hood and noticed significant smoke coming from what looks like the Clutch Slave Cyclinder. Not Coould be coming from directly below that or somewhere very close to that. Anyway, I did drive it the last mile up my driveway (kindof off road) and it was ok, didnt smoke but still had residual smell from the day before. I am not sure how to proceed. Any thoughts or similar experience would be appreciated. I am just getting into to auto mechanics so I am a novice at this point but I do have a lot of tools available and a couple people with more experience than me at my disposal. Thanks in advance!
     
    Lehma1989, May 23, 2020 at 3:41 PM
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.