My Subaru Is Making A Strange Noise, I Can't Find The Reason (EZ30)

Joined
Dec 3, 2022
Messages
1
Reaction score
0
My Subaru is a 2008 Legacy with an EZ30 engine, and it's making a noise I can't figure out why. The noise is on the left side (looking at the engine from the front), on the side where the air filter is located. The noise occurs below the intake manifold, and it appears when the air conditioning compressor activates, however the noise is on the opposite side where the compressor is. I have already changed the belt of accessories, pulleys and others, but nothing solved this noise. Another detail is that sometimes even with the air compressor activated the noise does not appear. In person it sounds a lot like a compression sound being lost. I recorded a video and posted it on YouTube, link below:
https://youtube.com/shorts/VcgBEux_PFg?feature=share
 
Does that engine control unit provide any recorded fault codes?
No variable valve timing faults?
With that noise, is there any pressure felt near the area?
For example, combustion pressure?
Did you check and test the PCV valve?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
14,030
Messages
67,736
Members
7,528
Latest member
unclehorm

Latest Threads

Back
Top