Shaking Subaru Legacy

Discussion in 'Subaru Legacy' started by justinpajski, May 11, 2016.

  1. justinpajski

    justinpajski

    Joined:
    May 11, 2016
    Messages:
    1
    Likes Received:
    0
    alright please someone help me out!! i have a 99 legacy sus limited 30th anniversary 2.5, well to start out i am having trouble with ALOT and i cannot for th life of me figure out whats wrong and soon I am just going to drive it into a lake!!!



    whats going on: when staring on coldstart idles fine and warms up good (most of the time) but sometimes it idles high then low, and the heating control lights flicker (sometimes). when i accelerate it seems to shake not to bad but you can for sure feel it then some times it drives fine and does not shake at all.... it also pulls (sometimes). it also every once in a wile seems to rev up when pressing on gas and doesn't really want to move, getting very shitty gas millage to...



    what I did/replaced

    -plugs and wires

    -temp sensor and thermostat

    -brakes and rotors

    -fuel pump

    -checked for vacuum leaks

    -checked tranny fluid

    -ran seafoam threw it

    -oil and filter change

    -replaced ground wires for battery

    -clean mas air flow sensor and throttle body
     
    justinpajski, May 11, 2016
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.