Blower Motor 1990 Loyale

I

issjoe

Blower fan wont work on any speed. The two 15 amp blower fuses are
good. The blower motor is good. There is no power to the plug that the
blower motor plugs into. There is a relay and the fan switch, but I
cant figure out how to get to either to test. They both seem to be
behind the dash.
 
Blower fan wont work on any speed. The two 15 amp blower fuses are
good. The blower motor is good. There is no power to the plug that the
blower motor plugs into. There is a relay and the fan switch, but I
cant figure out how to get to either to test. They both seem to be
behind the dash.


Check the brake lights. I'm not sure if the Loyale is wired the same,
but on a '90 Legacy, the blower fan is on the same circuit as the
brake lights. If you have a short there, it would make both stop
working.

Also, and I knwo this is a sort of fonzie-esque fix, try jiggling the
wire bundle that comes out the top of the fuse box. I used to have
trouble with that circuit, and if the blower moter went out, kicking
just above the fuse box usually made it come back on. (THere is also
usually a "No, I can't turn the heater off; I need to listen to it to
make sure my brake lights still work" step involved if you've got a
passenger)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
14,030
Messages
67,736
Members
7,528
Latest member
unclehorm

Latest Threads

Back
Top