2020 Subaru Legacy Sputtered and Died

Discussion in 'Subaru Legacy' started by ITEngineer, Jul 17, 2021.

  1. ITEngineer

    ITEngineer

    Joined:
    Jan 10, 2021
    Messages:
    8
    Likes Received:
    1
    Hi, Folks.

    I was driving my car today at about 30 MPH and it just started sputtering and jerking. The engine was non-responsive to attempts at acceleration. Was behaving perfectly fine before this. It finally slowed down and died altogether. It would not turnover again. Had to tow it to the dealer. The damn car is 8 months old with 15K miles on it. I take good care of the car. Change oil regularly. What the heck is going on?
     
    ITEngineer, Jul 17, 2021
    #1
    1. Advertisements

  2. ITEngineer

    anton980

    Joined:
    Aug 23, 2021
    Messages:
    3
    Likes Received:
    0
    It doesn't turn over at all? Is the battery/wiring good? Any lights in the dashboard showing when the key is in the ignition?
     
    anton980, Aug 23, 2021
    #2
    1. Advertisements

  3. ITEngineer

    joepilot

    Joined:
    Aug 5, 2020
    Messages:
    12
    Likes Received:
    2
    Location:
    Oshkosh, WI
    When it died, did all the warning lights on the dash come on? Did the electronic parking brake engage? If so, it may be a problem with the CVT. This happened to us twice in the first 7000 miles we owned the car. They ended up having to replace the transmission. All has been well since the new tranny was installed. (There is a thread on my issue elsewhere in these forums.)
     
    joepilot, Aug 23, 2021
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.