2015 Subaru Legacy horn won't stop blowing

Joined
May 28, 2023
Messages
3
Reaction score
0
My husband changed the spark plugs in our 2015 Legacy. He had to remove the battery to change the plugs. Now every time the battery is hooked up, the horn blows continously & the car won't start or respond in any way. Any ideas on what this could be?
 
The immobilizer was set, use the key to lock / unlock the vehicle and make sure the remotes are not damaged or pinched at the engine hood. If there is an aftermarket alarm or remote start, check into those components.
 
Not sure what remotes you are referring to. My key fobs get no response at all. Tried locking & unlocking with key, no luck. The car won't even lock with the key.
 
Key fobs or remotes . . same term. Go back to the scene of the crime when the battery was disconnected / removed.
Hopefully not connected backwards - seen that before.
Disconnect the horn / alarm and with the ignition key in the RUN position, check all the fuses. Identify the correct model.
 

Attachments

  • 2015 Legacy.png
    2015 Legacy.png
    2.4 KB · Views: 3
Still can't find anything blown. Battery is connected correctly. Car completely unresponsive. Going to have to have it towed to Subaru tomorrow. Thanks fir the suggestions.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
14,173
Messages
68,160
Members
7,691
Latest member
Bazuu

Latest Threads

Back
Top