2012 Impreza: Hissing @ center console w/ defrost & AC

Joined
Jul 30, 2019
Messages
2
Reaction score
0
Cars AC doesn't work, it might get a little colder but it's hard to tell. The compressor kicks on, the clutch spins, it is fully charged and there are no leaks in the system. The only thing that is off (besides the lack of cold air) is a hissing sound in the center console. That hissing sound is constant when I have the defrost or AC on; when I have the normal air vents going I don't get the noise. I plugged in my OBDII reader and Im not getting any trouble codes. Ive already swapped all of the fuses to test them.

Is this the blend air door? Is it something else? Im down to troubleshoot, but I can't afford taking it to the shop and it's been in the 90's all week. It's hot!

thanks for reading
 
bippity boppity bump.
but seriously, nothing has changed. The high pressure line is hot, the low pressure line is cold, but im not getting any condensed water underneath the car, and I dont think that im getting any cooling at all. I can't figure it out and I dont want to take it to the shop.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
14,117
Messages
67,993
Members
7,614
Latest member
Calvin W

Latest Threads

Back
Top