2010 Subaru Forester - is it dead? Electrical?

Joined
Oct 15, 2023
Messages
1
Reaction score
0
We bought a used 2010 Subaru Forester last month that was in pretty decent condition, but had P0420 for a code.

About a week later, the engine started stuttering/Skipping occasionally and code p0301 and p0303. We changed the spark plugs and wires, and it also had new brakes and calipers.

For two weeks, it was perfect.
Then this week, the skip came back, the codes came back. It started smoking a couple times. Then that stopped.
On the way to work yesterday, it just…died. It was skipping, then it cut out and I haven’t been able to start it again since.
It tries to turn over, but doesn’t start.

Any ideas?
It’s the perfect car for us and I’m not ready to give up on it!
 
My father in-law had a similar issue with his 2010 Forester. Dealer wanted to replace the engine; second opinion independent shop found a loose connection at the coil pack. All was good except the 0420 code which required some minor tuning of the ECU to go away. It's been running fine since. I think you should check/unplug/replug all connections.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
13,962
Messages
67,556
Members
7,446
Latest member
tmp1k

Latest Threads

Back
Top