2010 Subaru Forester Bulkhead Wiring Harness

Joined
Aug 1, 2022
Messages
3
Reaction score
0
Sometime this summer, the car started throwing codes. Oil at temp, abs, cruise. Check engine, traction control - all at once. Almost always at highway speeds. Not the gas cap as we have a new one…. Might check that but… anyway, we pull over. Turn off car. Restart. Oil at temp and ABS go off. The rest stay on until they clear a few miles on. Always clears.

Took it to Subaru. They spent a pretty good deal of time diagnosing it. They came up with recommendation to replace bulkhead wiring harness. 2200.00 plus about 3000.00 to install. Car is worth about that on a good day 156k miles. They are very clear that it is not the tranny. Everything seems operational.

Thoughts? Anyone seen this anywhere along the line? Should I be looking for a second opinion? Part quoted is 81402SC051. There’s a very good independent that specializes in Subaru a few towns over. Tempted to see what they say. Any thoughts or input will be appreciated.
 
Did anyone test for current fault codes recorded on the network?
Posting faults is a good step.
Did anyone test the circuit powers and grounds, especially the ground straps?
 
Did anyone test for current fault codes recorded on the network?
Posting faults is a good step.
Did anyone test the circuit powers and grounds, especially the ground straps?

Working on it. Have also received advice to check battery, ground strap. Progress shortly.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
13,962
Messages
67,556
Members
7,446
Latest member
tmp1k

Latest Threads

Back
Top