2006 Subaru Baja Turbo

Joined
Apr 1, 2023
Messages
1
Reaction score
0
I have a a new engine in my 2006 Subaru Baja with a couple thousand miles on it. My mechanic went with a catless downpipe which the car never got a tune for so when really jamming on it it would throw a code but would not affect any of the engine performance except for hesitating for just a moment. We had very fluctuating cold days with degrees in the negative 30s a couple times. It sounds like a lot of ecu's went down around this time due to the warming up of the moisture and then quickly freezing is the sun would go down. I accelerated somewhat heavily away from a stop sign after not letting the engine warm up and it threw misfire codes in all four cylinders after backfiring coming out of the stop sign. The ECU I sent in for repair did not fix the problem and I'm being told that if I didn't fix any of the other electrical stuff involved that that could be causing the ECU to fry out? I cleaned the O2 sensor which didn't help it'll start and run for a couple minutes and then start to sputter and choke out and then eventually die. Just trying to figure out what I can start fixing to try and get this problem solved. Thank you for your time
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
13,933
Messages
67,479
Members
7,409
Latest member
giuliatoschi

Latest Threads

Back
Top