2010 IMPREZA CHECK ENGINE LIGHT

Joined
Oct 26, 2023
Messages
13
Reaction score
1
Yesterday did a FULL FEUL up

This morning (montreal)
1st start failed

Then Checkine light came ON, VDC ON and cruise flashing.

2nd start worked and drove with the car.

Any ideas?
 
I checked engine code without scan tool and got
P----- NO CODE??

STRANGE, will check engine light turn off?

Or did I do something in correct?
 
Last edited:
UPDATE light came back on...I managed to capture code

P0340...any suggestions how serious this is?
 
UPDATE THIS MORNING
8AM STARTED CAR, CEL OFF...

intermittent ISSUE...

ANY SUGGESTION/IDEAS?
 
update this monring
7/45am started car no CEL
went to TIM HRTONS

8am STARTED car, STUTTERED...P0340 code came on CEL ON
 
I FORGOT TO MENTION..BUT AT THE SAME TIME CEL STARTED

I OBSERVED TOONIE SIZE HOLE IN MY EXHAUST SYSTEM.

CAN THAT BE THE ROOT CAUSE?
 
I was told to replace camshaft position sensor 1st and if issue still continues then next step...hmmmm not obvious...

If i replace part camshaft position sensor should I get original or other make?
 
I have picture of snesor covered in oil is that normal?

see photo
 

Attachments

  • oil covered pic 1.PNG
    oil covered pic 1.PNG
    214.9 KB · Views: 4

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
13,934
Messages
67,480
Members
7,409
Latest member
giuliatoschi

Latest Threads

Back
Top