2009 Impreza 2.5i clicking sound when accelerating.... what is it?

Joined
Sep 29, 2023
Messages
3
Reaction score
0
Hi this is my 2009 Impreza 2.5i is making this horrible clicking sound when you press on the gas pedal. It doesn't make this sound in neutral or when not moving. I looked underneath thinking it could be an exhaust leak. The exhaust is pretty solid so I'm not thinking so. I'm really hoping its not a spun bearing or something just as bad. Some opinions please?

 
I have the exact problem I’m thinking cv axles but it could be a bad cat broken engine mount or lengine low oil cuz it has a bad leak nobody but me cares about.. I will find out soon as she pulls it in the driveway and get back to you
 
I have the exact problem I’m thinking cv axles but it could be a bad cat broken engine mount or lengine low oil cuz it has a bad leak nobody but me cares about.. I will find out soon as she pulls it in the driveway and get back to you
I got under the car and it sounds like a diesel lol. I really hope it's not but I'm pretty sure its bearing noise
I was looking for an exhaust leak that I thought could be the reason for the noise.
Gonna take her into a shop tomorrow and see what they say
 
I put the car on stands today and got under it while it was in gear and driving. The clicking was coming from the manual transmission. Thank God it's not the motor. Time for some research
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
14,118
Messages
67,994
Members
7,615
Latest member
ocalajo

Latest Threads

Back
Top