Weird smell 2004 Legacy Sedan

Discussion in 'Subaru Legacy' started by TMK, Oct 15, 2009.

  1. TMK

    TMK Guest

    When turn the heat on in my 2004 Legacy get a smell like burning oil...car
    seems to run fine and heat fine but it concerns me. Any thoughts?

    TIA, TMK
     
    TMK, Oct 15, 2009
    #1
    1. Advertisements


  2. Possibly a torn CV joint boot is allowing grease to be thrown onto hot
    exhaust.

    It doesn't smell like toasted marshmalllows I hope (coolant)
     
    1 Lucky Texan, Oct 15, 2009
    #2
    1. Advertisements

  3. TMK

    TMK Guest

    Looked all over but not there...thanks for the reply will check in the
    morning!

    Regards, T



    Possibly a torn CV joint boot is allowing grease to be thrown onto hot
    exhaust.

    It doesn't smell like toasted marshmalllows I hope (coolant)
     
    TMK, Oct 15, 2009
    #3
  4. TMK

    Frank Guest

    Had this problem with my old Forester. Put it on oil change ramps,
    crawled under and saw spots on exhaust system that caused smell. It was
    repaired under the drive train warranty.
     
    Frank, Oct 15, 2009
    #4
  5. TMK

    TMK Guest

    Thank you...going to see dealer Sat or Mon...have the Gold Plus warranty;
    sure they will fix it...appreciate the input!

    T
     
    TMK, Oct 16, 2009
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.