Outback 2014 Electronics?

Discussion in 'Subaru Outback' started by bocash3, Apr 1, 2019.

  1. bocash3

    bocash3

    Joined:
    Apr 1, 2019
    Messages:
    1
    Likes Received:
    0
    Howdy to the board.

    2014 Outback, 2.5, Premium edition, 48,000 miles.

    A month ago, a mechanic left the oil filler cap off when changing oil.

    24 hours later, I noted the oil light came on. A full quart had blown out through the opening and all over the engine.

    This may have nothing to do with the current problem, however................

    Today after driving down a steep driveway, the Check Engine light, Brake Lights, Cruise Control symbol light, and what appears to be a Traction symbol light all came on. I stopped the vehicle, turned off the engine and let it rest a few minutes. When I cranked the engine to return home, all of these lights/warnings came back on again.

    Once home, I checked the oil and did a general scan of all wires under the hood and saw nothing wrong.

    What I am dealing with?

    Many thanks in advance, Bo Cash, western NC
     
    bocash3, Apr 1, 2019
    #1
    1. Advertisements

  2. bocash3

    dadskrej

    Joined:
    Feb 29, 2020
    Messages:
    2
    Likes Received:
    0
    Likely a loose gascap. I had the same with my 2013 Outback 2.5. Later, at 190k miles the catalytic converter went bad (came apart inside the converter) and those lights came on the same as the loose cap. Just a couple things I ran into.
     
    dadskrej, Feb 29, 2020
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.