Heater core replacement gone bad

Discussion in 'Subaru Impreza' started by Superu99, Mar 11, 2020.

  1. Superu99

    Superu99

    Joined:
    Mar 11, 2020
    Messages:
    1
    Likes Received:
    0
    I had a leaking heater core in my 05 Impreza 2.5RS, so I got a replacement and started tearing into my dash. About an hour later I had the entire dash removed. I successfully installed the replacement heater core and put everything back together. After I finished buttoning everything back up I reconnected the negative battery terminal. Heater works only on fan setting 4 and now I have a host of new problems. When I turn the key forward to the 'ON' (not running) position the relays on the passenger side start clicking and the cooling fan starts to run for a few seconds at a time, shuts off and repeats. BUT WAIT, theres more! When I start the car I have a FLASHING check engine light. I pulled the code and they are the following:
    P1518
    P0851
    P1152
    P1153
    P0137
    P0502
    I had 0 Check Engine lights when I started, car was fine besides the heater core. I looked up some of the codes and 2 are for heated o2 sensor and starter relay, so I'm wondering if I didn't spill some coolant on the starter and o2 sensor when I was pulling the heater core lines from the firewall and mess something up. Maybe not. Wtf is going on here? Need help ASAP, thanks in advance.
     
    Superu99, Mar 11, 2020
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.