05 LGT Stalling

Discussion in 'Subaru Legacy' started by AJLEGACY, Dec 8, 2019.

  1. AJLEGACY

    AJLEGACY

    Joined:
    Dec 6, 2019
    Messages:
    4
    Likes Received:
    0
    Hi all,

    I have a 05 LGT 5EAT with an ECU tune and I have an issue with my car. Everytime I put it into D it stalls out, the first time it happened was last year and I took it to a shop. They cleaned the throttle body and fixed a vacuum leak and the car was fine. Fast forward to a little over a year and the same issue happened 2 weeks back. I tried cleaning the MAF to see if could be that, no luck. Called over a mechanic who then got the code P1718 and P0700. Reset the battery and the car worked fine. Drove the car like normal Then again yesterday the same issue. Replaced TCM reset the battery, the car went into gear. Mechanic noticed that the idle seems a bit low, idling at about 500-600RPM. I heard someone who had the same issue and codes had LED brake lights and another one had a bad brake light switch. Any suggestions on what to do? We are both stumped at this point. Cheers in advance!
     
    AJLEGACY, Dec 8, 2019
    #1
    1. Advertisements

  2. AJLEGACY

    AJLEGACY

    Joined:
    Dec 6, 2019
    Messages:
    4
    Likes Received:
    0
    Update--mechanic cleaned the TB & replaced the TCM. Drove fine until it started idling rough. I now got the P0171 code. Mechanic will be coming back for that. Not sure if the rain may have damaged the connector or it shorted but the MAF was cleaned 2 weeks ago and it was replaced last year.
     
    AJLEGACY, Dec 9, 2019
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.